2

Nahimic 2.5.16 switches 5.1 to stereo when plugging in front speakers

Hi guys,

Hope you can help me with this issue.

When plugging in the FRONT speakers Nahimic switches from Device Properties>Format "5.1" to "stereo" and removes the "4.0", "5.1" dropdown options !

Scenario:

( Laptop GT72 Dominator Pro with Dynaudio,  Logitec x-530 5.1 surround speakers, Nahimic 2+ driver updated to v2.5.16, Windows 10 Home 64bit )

A)

NO external speakers plugged in, using internal Laptop speakers.

Nahimic showing  "INTERNAL SPEAKERS"(big blue icon top left)>Device Properties>Format dropdown options "stereo,4.0, 5.1"

Audio output works from internal speakers as expected selecting any dropdown option.

B)

Plugging in REAR speakers into the corresponding audio jack

Nahimic now showing  "SPEAKERS">Device Properties>Format dropdown options "stereo,4.0, 5.1"

selecting "5.1" (or "4.0" / stereo), audio comes from REAR speakers 

C)

<PROBLEM>

when additionally connecting the FRONT speakers:

"External audio device detected" window pops up with 

selection options "HiFi Headphones, Front Speaker Out, S/PDIF-Out"

selecting "Front Speaker Out" (as well as the others btw.) switches in

Nahimic "SPEAKERS">Device Properties>Format "5.1" to "Stereo" AND removes the dropdown options "4.0" and "5.1" !!

Audio now comes out of FRONT speakers ONLY,

NO AUDIO from the REAR speakers.

thanks for your help,

cheers,

enrico

2 replies

Can you also give me the Realtek version? 

Hello Enrico, 

I give that to my tester to check that behavior.

Thanks!